Dragon

安装OpenCV于Python3.7&2.7

2020-10-20 16:14 108 抢沙发 小逸博客

最新的树莓派系统中预装了python2.7和python3.7两个版本,但是系统中自带的Thonny Python IDE程序编译软件 “貌似” 只能运行python3的代码,这就为python2程序的编写造成了一定的困扰。

另外,现在市面上 “大多数” 的库文件都用python3编写,所以我们优先选择安装OpenCV于Python3中,以备以后更好的使用。

更新完系统之后我们就能从官方渠道下载库文件,在命令窗中敲以下代码:

$ sudo apt-get update      //更新软件源
$ sudo apt-get upgrade      //更新系统软件

如果你想要更快的速度推荐使用国内清华源如何给树莓派更换软件源

$ sudo apt-get install python3-opencv      //安装python3-opencv
$ sudo apt-get install python-opencv      //安装python2-opencv(可选)

安装需要几分钟左右。在完成之后,你可以在终端输入:

$ python3           //运行python3,如果需要验证python2直接替换即可
$ import cv2        //无error则表示安装成功

 
如遇疑难杂症进入赞助页面加站长微信好友站长帮你解决,或评论留言

网上还有许多方式安装,比如直接编译,还有pip安装
pip官方我没找到匹配于python2.7和3.7的opencv库,貌似是不支持这两个版本的
博主大力推荐本帖的安装方式最快捷也是最简单的

已安装的OpenCV版本(当前为3.2.0)均不支持C ++。另一个可能的陷阱可能是存储库。一旦使用新版本更新了该生态系统,诸如sudo apt-get upgrade之类的简单命令将自动安装与3系列不兼容的4.0.0或更高版本。除非您已将 OpenCV 隔离在虚拟环境中,否则您将面对旧项目上的一些耗时的修复工作。最重要的是,甚至更糟的是,安装的版本并未针对Raspberry Pi的 NEON-ARM 内核进行优化。具体教程如何链接
树莓派在Raspberry Pi 4上安装OpenCV 4.4.0

「点点赞赏,手留余香」

还没有人赞赏,快来当第一个赞赏的人吧!

Mr-XiaoYi给Mr-XiaoYi打赏
×
予人玫瑰,手有余香
  • 2
  • 5
  • 10
  • 20
  • 50
2
支付

本文为原创文章,版权归所有,欢迎分享本文,转载请保留出处!

2020-10-20

2020-10-20

发表评论

表情 贴图 链接 私密 格式 签到
扫一扫二维码分享